In Excel mit dem Datum rechnen

1. Tage zu einem Datum addieren bzw. von einem Datum subtrahieren

Ein Liefervertrag sieht z.B. vor, dass die bestellte Ware 5 Tage nach Bestellung geliefert wird.

Schreibe dazu in O9 die Formel

=M9+N9

und ziehe sie mit dem Ausfüllkästchen bis O12 herunter.

Datum1

Nun steht in O9:O12 jeweils das voraussichtliche Lieferdatum.

Du stellst aber fest, dass der 10.06.2018 ein Sonntag ist. An diesem Tag wird es keine Lieferung geben.

Stelle deshalb zunächst fest, ob der Liefertermin ein Sonntag sein wird. Das machst Du mit der REST-Funktion.

=REST(M9+N9;7)

Das Ergebnis ist 1 und für Excel der Sonntag.

Schreibe die gesamte Formel nun so:

=WENN(REST(M9+N9;7)=1;M9+N9+1;M9+N9)

Das Ergebnis ist der „11.06.2018“.

Als Liefertermin wird Dir nun der 11.06.2018, ein Montag genannt.

Datum2

Das Subtrahieren von Tagen von einem Datum geht analog.

2. Wochen zu einem Datum addieren bzw. von einem Datum subtrahieren

Angenommen, die Lieferfrist soll 2 Wochen betragen. Führe die Addition bzw. Subtraktion durch, indem Du die angegebenen Wochen mit 7 (Tage pro Woche) multiplizierst.

Schreibe diese Formel in M46 und ziehe sie herunter.

=M46+(N46*7)

Datum3

Im Beispiel ist kein voraussichtlicher Liefertermin ein Sonntag. Dennoch kann es vorkommen.

Schreibe also, ähnlich Abschnitt 1, die Formel in M46 so:

=WENN(REST(M46+(N46*7);7)=1;M46+(N46*7)+1;M46+(N46*7))

Die Lieferdaten ändern sich nicht.

Das Subtrahieren von Wochen von einem Datum geht analog.

3. Monate zu einem Datum addieren bzw. von einem Datum subtrahieren

Zum Addieren bzw. Subtrahieren von Monaten wird die Funktion EDATUM verwendet. Mit EDATUM können z.B. Rückzahlungs- oder Fälligkeitstermine berechnet werden.

Angenommen, ein Kredit mit einjähriger Laufzeit soll vierteljährlich, also alle drei Monate getilgt werden, die auf denselben Tag eines Monats fallen wie der jeweilige Emissionstermin.

Der Kredit i.H.v. 50.000 € wurde am 15.06.2018 ausgezahlt. Die Tilgung beträgt jeweils 12.500 € (50.000 / 4).

Datum4

Das Ausgangsdatum in M77 wird direkt eingegeben.

Schreibe in M78 die Formel

=EDATUM(M77;3)

Ziehe die Formel bis M81 herunter.

Willst Du Monate subtrahieren, schreibe das Argument „Monate“ in EDATUM negativ.

=EDATUM(M77;-3)

Die Berechnung kannst Du gleichermaßen auch mit der Funktion DATUM ausführen.

=DATUM(JAHR(M77);MONAT(M77)+3;TAG(M77))

Ergebnis: 15.09.2018 usw.

4. Jahre zu einem Datum addieren bzw. von einem Datum subtrahieren

Jahre zu einem Datum addieren bzw. subtrahieren, ist relativ einfach. Das Ausgangsdatum soll der 11.07.2018 sein. Drei Jahre sollen hinzu addiert werden.

Datum5

Verwende die Funktion DATUM in B119:

=DATUM(JAHR(B113)+3;MONAT(B113);TAG(B113))

Ergebnis:

Datum6

Dem Argument Jahr werden einfach 3 hinzugerechnet.

Die Subtraktion nimmst Du analog vor.

5. Jahre, Monate und Tage zu einem Datum addieren bzw. von einem Datum subtrahieren

Zu einem Ausgangsdatum sollen 2 Jahre, 2 Monate und 2 Tage hinzu addiert werden.

Datum7

Schreibe in C131 die Formel:

=DATUM(JAHR(C129)+2;MONAT(C129)+2;TAG(C129)+2)

Bei der Subtraktion gibt’s Du jeweils Negativwerte ein.

Advertisements

Die Excel -Funktion UND

Die Funktionen UND bzw. ODER werden häufig verwendet, um für Wahrheitsprüfungen mehrere Bedingungen zu berücksichtigen. Um den Nutzen anderer Funktionen zu erhöhen, werden sie z.B. in der WENN-Funktion als Argument für die Prüfung eingesetzt.

Die Funktionen für sich allein verwendet, geben immer einen Wahrheitswert aus, entweder WAHR oder FALSCH.

In diesem Beitrag geht es nur um die UND-Funktion.

Weiterlesen „Die Excel -Funktion UND“

Gliedern in Excel mit dem Teilergebnis

Wenn Du umfangreiche Verkaufs- oder Umsatzlisten hast, besteht in der Regel auch der Wunsch, diese Listen nach Produkt, Verkaufsort, Bundesland, Datum oder Umsatzhöhe zu gliedern.

Das kannst Du sehr gut mit einer Pivottabelle tun. Erste Schritte dazu habe ich Dir hier gezeigt.

Eine weitere Möglichkeit ist das Gliedern der Tabelle. In diesem Beitrag geht es um die Gliederung mit der Funktion Teilergebnis.

Weiterlesen „Gliedern in Excel mit dem Teilergebnis“

Integrierte Eingabemaske in Excel

Wenn Du Dir eine Kundenliste in Excel anlegen möchtest, wirst Du zunächst eine Kopfzeile anlegen, etwa so:

Eingabemaske1

Zur Dateneingabe wirst Du entweder eine Zeile nach der anderen markieren und die Daten eintragen oder Dich mit den Pfeiltasten hindurch hangeln.

Es geht aber auch etwas komfortabler. Excel hat eine Eingabemaske im Angebot, die Du allerdings nirgends im Menü findest.

Weiterlesen „Integrierte Eingabemaske in Excel“

Optimale Programmplanung mit dem Solver in Excel

Gewinnmaximierung gehört neben anderen Zielen wie z.B. Kostensenkung immer zu den Zielen eines Unternehmens.

Verhalten sich die zu betrachtenden Kennzahlen linear, werden auch Methoden der linearen Optimierung angewendet werden, um dem Ziel näher zu kommen.

Dieser Beitrag zeigt, wie in Excel mit dem Solver solche Berechnungen durchgeführt werden können.

Weiterlesen „Optimale Programmplanung mit dem Solver in Excel“

Ein gruppiertes Balkendiagramm in Excel erstellen

Balkendiagramm sind ein weiterer Diagramm-Typ zur Verschaulichung von Daten, die in Zeilen oder Spalten eines Arbeitsblattes zu finden sind. Sie sind optimal zum Vergleichen mehrerer Werte geeignet.

Excel bietet diesen Diagrammtyp in folgenden Varianten an:
– 2D-Balken
– 3D-Balken
– Zyklinder
– Kegel
– Pyramide

Alle Varianten gibt es dann noch einmal unterteilt in:
– gruppiert
– gestapelt
– gestapelt (100%)

In diesem Beitrag geht es nur um die gruppierten 2D-Balken.

Weiterlesen „Ein gruppiertes Balkendiagramm in Excel erstellen“

Excel-Minis 02/2018

In diesem Beitrag findest du kurze Beiträge zu diesen Themen:

  • Der Filter im Namensmanager
  • Filtern mit dem Datenschnitt
  • Reihen bilden mit dem Füllbereich

Weiterlesen „Excel-Minis 02/2018“