Formelanalyse in Excel – Bezüge einfärben

Irgendwann ist es wohl jedem von uns schon mal so gegangen. Wir sind in einem interessanten Beitrag oder in einer fremden Arbeitsmappe auf eine Formel gestoßen, die wir nicht auf Anhieb verstanden haben.

Wenn Du gelegentlich oder regelmäßig mit Excel arbeitest, willst Du wissen, wie eine Formel arbeitet.

Hier hilft Dir eine Formelanalyse. Dieser Beitrag und folgende sollen Dir Möglichkeiten aufzeigen.

1. Einfärbung von Bezügen

Beim Eingeben einer Formel werden Bezüge eingefärbt.

2. Beispiel 1

Angenommen, Du hast eine Liste mit den Umsätzen von vier Filialen eines Unternehmens im I. Quartal eines beliebigen Jahres.

Wenn Du im Bereich B9:D9 die Formel

=SUMME(B5;B6;B7;B8)

eingibst, färben sich die Argumente in der Formel unterschiedlich ein. Gleichzeitig werden die Bezugszellen mit einem farbigen Rahmen versehen. Die Farben entsprechen denen der Argumente.

So ist z.B. B5 als Argument blau gefärbt, ebenso ist die Zelle B5 eingerahmt.

Aktivierst Du zu einem späteren Zeitpunkt z.B. die Zelle B5, werden die Zellen B5:B8 farbig gerahmt gezeigt. Die Farben der Argumente siehst Du in der Bearbeitungszeile.

Wenn Du dagegen im Bereich B9:D9 die Formel

=SUMME(B5:B8)

eingibst, wird B5:B8 als ein Argument blau gefärbt. Der Bereich B5:B8 erhält als Ganzes einen blauen Rahmen.

Was nützt Dir diese Möglichkeit nun? Du kannst auf Anhieb erkennen, welche Zellen eine Formel für die Berechnungen nutzt.

3. Beispiel 2

Verwende wieder die Umsatzliste aus Beispiel 1.

Diesmal willst Du den Umsatz einer bestimmten Filiale in einem bestimmten Monat abfragen. Bei der vorliegenden Beispielliste brauchst Du dazu keine Formel, das kannst Du auch so ablesen.

Aber bei einem wesentlich größeren Unternehmen und Monaten eines ganzen Jahres kann eine Formel schon hilfreich sein.

Hinterlege in B11 eine Drop-Down-Liste „Filiale“, die Du im Menü Daten / Datentools / Datenüberprüfung angelegt hast.

Hinterlege in B13 eine Drop-Down-Liste „Monat“, die Du ebenfalls angelegt hast.

Schreibe in B15 nun die Formel

=INDEX(B5:D8;VERGLEICH(B11;Filiale;0);VERGLEICH(B13;Monat;0))

Du siehst in der Abbildung die Einfärbungen der Argumente und die farbigen Rahmen in den Bezugszellen.

Die gilt sowohl für die Hauptfunktion INDEX als auch für die Hilfsfunktionen VERGLEICH zur Bestimmung von Zeile und Spalte in der INDEX-Funktion.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s