Dynamische Diagramme in Excel erstellen

Diagramme in Excel zu erstellen ist relativ einfach. Ein Diagramm bleibt übersichtlich, wenn nur ein oder zwei Datenreihen darin verarbeitet werden.

Enthält die Wertetabelle jedoch weitere Datenreihen, kann es schon kompliziert werden.

Im Beitrag zeige ich Dir, wie Du eine Dynamik erzielen kannst, indem Du nur jeweils eine Datenreihe für das Diagramm auswählst.

1. Die Wertetabelle

Die Tabelle zeigt die monatlichen Produktionsmengen eines Möbelherstellers für vier Produkte.

2. Diagramm für alle Produkte

Markiere den Bereich A3:M6 und erstelle über Einfügen / Diagramme ein Liniendiagramm mit Datenpunkten.

Was könnte Dich stören?

Die Linien verlaufen scheinbar recht gleichmäßig, zeigen nicht gewisse Unterschiede zwischen den Monaten.

Die Linien von drei Produkten liegen relativ dicht beieinander. Bei dichter zusammen liegenden Werten könnte das zu einer Überlappung führen.

Deine Idee ist deshalb, jeweils nur ein Produkt im Diagramm darzustellen. Dazu benötigst Du eine Umschaltmöglichkeit.

3. Dynamisches Diagramm

Um nun dynamisch nur ein Produkt im Diagramm abzubilden, erweiterst Du das Arbeitsblatt wie folgt:

Such Dir eine Zelle aus, in der Du mittels Datenüberprüfung eine Liste hinterlegen willst. Im Beispiel wurde dafür die Zelle A14 gewählt.

Die Liste besteht aus den vier Produkten.

Rufe dazu im Menü Daten die Datenüberprüfung auf. Wähle unter „Zulassen“ die Liste.

Trage als Quelle den Bereich aus Deiner Wertetabelle ein, der die Produkte enthält. Bestätige mit OK.

Jetzt brauchst Du noch eine Zelle „Linked Cell“, im Beispiel B8.

Trage in B8 die Formel

=VERGLEICH(A14;A3:A6;0)

ein. Als Ergebnis erhältst Du jeweils die Position des in A14 ausgesuchten Produktes in der Liste.

Abschließend übernimmst Du in A10:M10 nochmals den Kopf Deiner Wertetabelle.

In den Zellen A11:M11 übernimmst Du mit der Formel

=INDEX(A3:A6;$B$8)

die Werte des ausgewählten Produktes aus der Wertetabelle.

Nun bleibt nur noch die Erstellung des Diagramms. Markiere den Bereich A11:M11 und erstelle über Einfügen / Diagramm ein Liniendiagramm mit Datenpunkten.

Angenommen, Du hast in A14 „Tisch“ als Produkt ausgewählt, nimmt das Diagramm die entsprechenden Werte auf.

Formatiere das Diagramm abschließend noch nach Deinen Vorstellungen.

Suche zum Test jetzt noch in A14 ein anderes Produkt aus, z.B. „Bett“. Das Diagramm passt sich daraufhin dynamisch den geänderten Werten an.

4. Fazit

Offensichtlich ist, dass bei Auswahl eines einzelnen Produktes die monatlichen Unterschiede der Werte viel deutlich herausgearbeitet werden als in der Gesamtdarstellung gemäß Abschn. 2.

Beispieldatei:

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s