Wie in Excel eine Matrix definiert werden kann

(Neubearbeitung 12.06.2021)

Matrizen werden in vielen Excel-Funktionen als Kriterium benötigt, z.B.

INDEX                     =INDEX(Matrix;Zeile;Spalte)
SUMMENPRODUKT   =SUMMENPRODUKT(Array1;Array2; …)
SUMMEWENN            =SUMMEWENN(Bereich;Suchkriterium;Summe Bereich)
MTRANS                          =MTRANS(Matrix)
VERGLEICH             =VERGLEICH(Suchkriterium;Suchmatrix;Vergleichstyp)
u.a.m.

Wie definiert sich eine Matrix nun?

Mit der INDEX-Formel zeige ich, wie die Matrix angewandt wird.

1. über die Werte eines Bereichs

=INDEX(B2:B6;2;1)

=38

2. über Werte in geschweiften Klammern

{25;38;;99;12;1245}

=INDEX({25;38;99;12;1245};2;1)

=38

3. über einen namentlich benannten Bereich

Name B8:B12: „Werte“

=INDEX(Werte;2;1)

=38

4. über eine Definition im Namensmanager

Name: „Matrix1“

bezieht sich auf: B14:B18

=INDEX(Matrix1;2;1)

=38

5. Erzeugung der Matrix durch Berechnung

Die Matrix entsteht aus der Multiplikation der Werte in Spalte B mit den Werten in Spalte C, z.B. 3 * 38 = 114.

=INDEX((B20:B24)*(C20:C24);2;1)

=114

Diese Form der Matrix ist im Tabellenblatt nicht zu sehen, wird aber durch die Multiplikation erzeugt.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s