Excel: Nach Farben filtern, sortieren, rechnen

Eine doch häufiger gestellte Frage ist, wie eine Excel-Liste oder eine Excel-Tabelle nach Farben gefiltert und sortiert werden kann.

Ebenso scheint es interessant zu sein, ob und wie mit Farben Berechnungen machbar sind.

Mit diesen Fragen beschäftigt sich dieser Beitrag.

1. Nach Farben filtern

Erstelle Dir zunächst eine Liste mit einer Reihe von Zahlenwerten.

Formatiere die einzelnen Zellen mit unterschiedlichen Füllfarben.

Aktiviere zum Filtern die Zellen B3:B13. Gehe dann im Menü Start auf Bearbeiten / Sortieren und Filtern und klicke auf Filtern.

In Zelle B3 erscheint nun ein kleiner Filterpfeil.

Klicke auf diesen Pfeil. Es erscheint eine Auswahlmöglichkeit. Gehe dort auf „Nach Farbe filtern“ und wähle die gewünschte Farbe, z.B. grün.

Übrig bleibt eine Teilliste mit den grün hinterlegten Zellen.

Beachte, die Zeilen mit anderen Farben sind ausgeblendet.

Willst Du die Liste wieder komplett sehen, klicke auf eine Zelle in der Liste, gehe im Menü Start wieder auf Bearbeiten / Sortieren und Filtern und klicke auf Filtern.

Eine weitere Möglichkeit, nach Farben zu filtern, ist der Weg über die rechte Maustaste.

Markiere dazu die Liste samt Überschrift und gehe mit der Entertaste auf eine gewünschte Farbe. Klicke mit der rechten Maustaste und gehe auf „Filter“. Wähle dann „Nach der Farbe der ausgewählten Zelle filtern“. Du erhältst wiederum eine Teilliste mit den entsprechend hinterlegten Farben.

In der beschriebenen Art und Weise kannst Du auch nach Schriftfarben filtern.

2. Nach Farben sortieren

Markiere zuerst den Bereich B3:B13. Gehe im Menü Start auf Bearbeiten / Sortieren und Filtern und klicke auf „Benutzerdefiniertes Sortieren“.

Wähle im Auswahlmenü unter „Sortieren nach“ mit dem kleinen Pfeil „Zellenfarbe“ aus.

Bestimme anschließend noch die farbliche Reihenfolge. Dazu fügst Du jeweils eine weitere Ebene ein. Im Beispiel wurde für gelb-grün-blau entschieden.

Nun liegt Dir die Liste farblich sortiert vor. Willst Du die ursprüngliche Liste wieder zurück haben, kannst Du die Sortierung mit dem Rückgängig-Pfeil rückgängig machen. Besser wäre, vor dem Sortieren eine Kopie anzufertigen und diese zu sortieren.

Auch hier besteht die Möglichkeit, eine Sortierung mit der rechten Maustaste vorzunehmen.

Markiere dazu den Bereich B4:B13, klicke die rechte Maustaste und wähle „Ausgewählte Zellenfarbe nach oben sortieren.

Hast Du gelb ausgesucht, erscheinen die drei gelben Zellen oben, alle anderen Zellen bleiben unsortiert.

Wählst Du als nächste Farbe nun grün, erscheinen die vier grünen Zellen oben, dann kommen die drei im vorangegangenen gelben Zellen und letztlich die drei blauen Zellen.

Sollen die gelben Zellen ganz oben stehen, klicke noch einmal in eine gelbe Zelle und lass nochmals sortieren. Dann ist die Reihenfolge gelb-grün-blau.

Einfacher allerdings ist der Weg über das Menü Start / Bearbeiten, wie oben beschrieben.

In der beschriebenen Art und Weise kannst Du auch nach Schriftfarben sortieren.

3. Nach Farben rechnen

Um nach Farben rechnen zu können, müssen in einem ersten Schritt die Farben bestimmt werden. Das können die Farben des Zellhintergrundes oder die Schriftfarben sein.

Markiere zuerst den Bereich B4:B13 und gib ihm über das Menü Formeln / Definierte Namen unter „Namen definieren“ den Namen

 „Farben“.

Trage unter „Formel bezieht sich auf“ bei Zellfarben

=ZELLE.ZUORDNEN(63;INDIREKT(„ZS(-1)“;))

und bei Schriftfarben

=ZELLE.ZUORDNEN(24;INDIREKT(„ZS(-1)“;))

ein.

Gib in C4 jetzt

=Farben

ein und ziehe die Formel bis C13 herunter.

Dort erscheinen jetzt die Farbcodes für die Zellfarben in B4:B13.

Natürlich kannst Du diese Codes auch in einem nicht sichtbaren Bereich hinterlegen.

Was kannst Du nun rechnen?

Drei kleine Beispiele sollen Dir das verdeutlichen.

Vielleicht möchtest Du wissen, wie viele Zellen mit der grünen Farbe belegt sind. Für grün lautet der Code 43.

Schreibe dazu die Formel

=ZÄHLENWENN(C4:C13;43)

Als Ergebnis wird Dir „4“ ausgegeben, es gibt also vier grüne Zellen.

Oder Du möchtest die Summe über alle blau markierten Zellen bilden, der Code ist hier 15.

Schreibe die Formel

=SUMMEWENN(C4:C13;15;B4:B13)

Als Ergebnis erhältst Du „292“.

Und drittens möchtest Du eventuell den Mittelwerte aller gelb markierten Zellen wissen. Der Code für gelb ist 44.

Schreibe also

=MITTELWERTWENN(C4:C13;44;B4:B13)

Das Ergebnis lautet „117,667“.

Weitere Berechnungen sind denkbar. Probiere es aus und lass alle Leser über einen Kommentar über Deine Erfahrungen daran teilhaben.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s