Bedingte Formatierung in Excel: Summanden von SUMMEWENN zeigen

Die Funktionen SUMMEWENN, SUMMEWENNS, MITTELWERTWENN oder MITTELWERTWENNS sind Dir bekannt. Nachteilig erscheint es mitunter, dass die in die Ergebnisse einfließenden Zellwerte nicht sichtbar sind.

Eine Möglichkeit, sie hervorzuheben, ist die bedingte Formatierung.

Wie Du das realisieren kannst, zeigt dieser Beitrag.

1. Die Basisdaten

Zur Darstellung der SUMMEWENN-Funktion und der bedingten Formatierung wird im Beispiel auszugsweise eine Liste der größten Städte Deutschlands verwendet. Am Ende des Beitrags findest Du eine Downloadmöglichkeit.

Die folgende Abbildung zeigt die ersten 20 Städte:

BedFormSUMM1

Die Originalliste enthält die Einwohnerzahlen aus weiteren Jahren, dies ist aber für den Zweck des Beitrags unerheblich.

2. Die Funktion SUMMEWENN

Es sollen in der Liste z.B. alle Städte aus dem Bundesland Bayern gefunden und die Einwohnerzahlen summiert werden.

Dazu verwendest Du die Funktion SUMMEWENN so:

=SUMMEWENN(D9:D84;“*Bayern“;C9:C84)

Als Ergebnis erhältst Du

2.770.657 (Einwohner)

3. Die Summanden mit bedingter Formatierung hervorheben

Wenn Du die in die Summe eingeflossenen Werte nun in der Liste sehen willst, setze die bedingte Formatierung ein.

Markiere dazu C9:C84 und rufe im Menü „Formatvorlagen“ die „Bedingte Formatierung „ auf.

Wähle dort „Formel zur Ermittlung der zu formatierenden Zellen verwenden“ aus.

Schreibe dort diese Formel:

=WENN(D9=“Bayern“;1)

und wähle unter Formatieren z.B. eine passende Ausfüllfarbe.

Nachdem Du „OK“ gegeben hast, sind die zutreffenden Zellen farblich hervorgehoben, in der Abbildung siehst Du ein paar formatierte Zellen.

BedFormSUMM2

Gestalte das Ganze etwas variabler, indem Du z.B. in Zelle B87 das gesuchte Bundesland einträgst oder dort eine Drop-Down-Liste anlegst.

In Zelle B89 schreibst Du dann die Formel

=SUMMEWENN(D9:D84;B87;C9:C84)

Für die bedingte Formatierung verwendest Du statt dem Text mit dem Bundesland einen Bezug auf B87.

=WENN(D9=$B$87;1)


Je nach Auswahl in B87 erhältst Du die zutreffende Summe und die Hervorhebung der Summanden.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s