Die Excel-Funktion ODER

Die Funktion ODER wird, wie die Funktion UND, häufig verwendet, um für Wahrheitsprüfungen mehrere Bedingungen zu berücksichtigen.

Oftmals wird sie in die WENN-Funktion als Argument für die Prüfung eingesetzt.

Die Funktion für sich allein verwendet, gibt immer einen Wahrheitswert aus, entweder WAHR oder FALSCH.

Die Funktion UND wurde in einem früheren Beitrag beschrieben. Erläuterungen und Beispiele findest Du unter diesem Link.

In diesem Beitrag geht es um die ODER-Funktion.

1. Die ODER-Funktion

Die Syntax stellt sich so dar:

ODER(Wahrheitswert1;[Wahrheitswert2]; …)

Der Wahrheitswert1 ist erforderlich. Hier handelt es sich um die erste zu prüfende Bedingung, die entweder als WAHR oder als FALSCH bewertet werden kann. Mit dem Wahrheitswert1 ist die Funktion schon arbeitsfähig.

Ein Beispiel:

In Zelle B4 steht die Zahl „1234“. Schreibe z.B. in Zelle D4 die Formel:

=ODER(B4=1234;B4=4321)

ODER1

Die Funktion prüft, ob in B15 die Zahl 1234 oder die Zahl 4321 steht. Das ist der Fall und somit ist das Prüfergebnis „WAHR“.

Um zu diesem Prüfergebnis zu kommen, reicht allerdings auch schon die Formel

=ODER(B4=1234)

aus. Schon damit erhältst Du ein „WAHR“.

Der Sinn der Funktion ODER liegt jedoch darin, mehrere Bedingungen zu setzen, wovon eine zutreffen muss, damit ein „WAHR“ herauskommt.

Und jetzt kommt das nächste Argument ins >Spiel. Wahrheitswert2 ist optional aber eine zusätzlich zu prüfende Bedingung, die entweder als WAHR oder als FALSCH bewertet werden kann. Maximal können in ODER insgesamt 255 Bedingungen angegeben werden.

Ein Beispiel:

In Zelle B8 steht die Zahl 1234, in B9 die Formel =823/10 und in B10 das Wort WAHR.

Schreibe  z.B. in Zelle D8 die Formel

=ODER(B8=1234;B9=564/10;B10=FALSCH)

ODER2

Mindestens eine der Bedingungen wird eingehalten, deshalb ist das Ergebnis WAHR.

Verändere nun z.B. den Wert in Zelle B8 auf 1235. Jetzt wird auch die eine, bisher wahre, Bedingung nicht eingehalten, deshalb ist das Ergebnis FALSCH.

2. Die ODER-Funktion als Argument

Mit der WENN-Funktion würdest Du die Formel so aufbauen:

=WENN(B8=1234;WENN(B9=564/10;WENN(B10=WAHR;WAHR;FALSC)))

Ergebnis: WAHR

Verwende nun ODRE als Prüfargument:

=WENN(ODER(B8=1234;B9=564/10;B10=WAHR);WAHR;FALSCH)

Ergebnis: WAHR

Was hast Du damit gespart? Die Formel ist nicht mehr geschachtelt. Alle Prüfbedingungen sind mit der ODER-Funktion zusammengefasst.

3. Mit der Funktion WENNFEHLER

lassen sich einzelne Zellinhalte auf Fehler prüfen.

Ein Beispiel:

In Zelle B13 steht die Zahl 2345, in B14 der Text „Wolke“. In D13 soll B13 durch B14 dividiert werden.

Schreibe in D13 die Formel:

=WENNFEHLER(B13/B14;“Berechnung nicht möglich“)

ODER3

Eine Zahl kann nicht durch einen Text dividiert werden, deshalb erhältst Du in D13 die Mitteilung „Berechnung nicht möglich“.

Ersetze den Wert in B14 durch eine Zahl. In D13 steht nun das Berechnungsergebnis.

ODER4

Um die ODER-Funktion auch hier zu nutzen, brauchst Du weitere Zellinhalte.

In B17 soll die Zahl 27, in B18 die Zahl 15 stehen. Beide Werte willst Du in D17 multiplizieren. Zusätzlich verwendest Du die Werte aus B13:B14.

Schreibe in D17 diese Formel:

=WENNFEHLER(ODER(B13/B14;B17*B18);“Das geht so nicht!“)

ODER5

Warum wird „Das geht so nicht!“ ausgegeben? Weil das erste Argument in ODER, nämlich B13/B14 mit FALSCH bewertet wird. Insofern liegt ein Fehler vor.

Ersetzt Du nun den Wert in B14 wieder durch eine Zahl, wird in D17 ein WAHR ausgegeben, denn ODER führt eine Wahrheitsprüfung durch.

Abschließend noch eine dritte Funktion,

4. Die NICHT-Funktion

Diese Funktion prüft, ob ein Wert nicht mit einem bestimmten Wert übereinstimmt. Die Werte können numerisch, aber auch alphanumerisch oder Text sein.

ODER6

Der Wert in B21, Wolke, ist WAHR, weil er nicht Wind ist usw.

Veränderst Du den Wert in B21 auf „Wind“, gibt die NICHT-Funktion in D21 FALSCH aus. Das wiederum ist hier richtig.

Setze nun die ODER-Funktion als Argument in NICHT ein:

=NICHT(ODER(B21=“Wind“;B22=5630;B23=“ZTE 88″))

Das Ergebnis ist WAHR, denn alle Bedingungen sind nicht wahr.

Veränderst Du einen Wert in B21:B23 so, dass darin der nicht gewollte Wert steht, z.B. B22 auf 5630, verändert sich das Ergebnis auf FALSC.

Die Antwort „FALSCH“ erhältst Du immer dann, wenn mindestens eine der ODER-Bedingungen erfüllt ist.

Veränderst Du alle Werte auf die nicht gewollten Inhalte, als B21 auf „Wind“, B22 auf 5630 und B23 auf „ZTE 88“, erhältst Du als Prüfergebnis FALSCH, denn alle Bedingungen zusammen treffen zu.

Für die Funktion NICHT ist das falsch.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s