Die Excel -Funktion UND

Die Funktionen UND bzw. ODER werden häufig verwendet, um für Wahrheitsprüfungen mehrere Bedingungen zu berücksichtigen. Um den Nutzen anderer Funktionen zu erhöhen, werden sie z.B. in der WENN-Funktion als Argument für die Prüfung eingesetzt.

Die Funktionen für sich allein verwendet, geben immer einen Wahrheitswert aus, entweder WAHR oder FALSCH.

In diesem Beitrag geht es nur um die UND-Funktion.

Die UND-Funktion

Die Syntax stellt sich so dar: UND(Wahrheitswert1, [Wahrheitswert2], …)

Der Wahrheitswert1 ist erforderlich. Hier handelt es sich um die erste zu prüfende Bedingung, die entweder als WAHR oder als FALSCH bewertet werden kann. Mit dem Wahrheitswert1 ist die Funktion schon arbeitsfähig.

Ein Beispiel:

In Zelle B25 steht die Zahl 1234. Schreibe z.B. in Zelle D25 die Formel =UND(B23=1234).

UND1

Die Funktion prüft, ob in B25 tatsächlich die Zahl 1234 steht. Das ist der Fall und somit ist das Prüfergebnis „WAHR“.

Um zu diesem Prüfergebnis zu kommen, reicht allerdings auch schon die Formel „=B25=1234“ aus. Schon damit erhältst Du ein „WAHR“.

Der Sinn der Funktion UND liegt darin, mehrere Bedingungen zu setzen, die alle zutreffen müssen, damit ein „WAHR“ herauskommt.

Und jetzt kommt das nächste Argument ins Spiel. Wahrheitswert2 ist optional. Das ist eine zusätzlich zu prüfende Bedingung, die entweder als WAHR oder als FALSCH bewertet werden kann. Maximal können in UND insgesamt 255 Bedingungen angegeben werden.

Ein Beispiel:

In Zelle B42 steht die Zahl 1234, in B43 die Formel =255/10 und in B44 das Wort WAHR.

Schreibe z.B. in Zelle D42 die Formel =UND(B42=1234;B43=255/10;B44=WAHR).

UND2

Die Bedingungen werden alle eingehalten, deshalb ist das Ergebnis WAHR.

Verändere nun z.B. den Wert in Zelle B42 auf 1235. Jetzt wird eine Bedingung nicht eingehalten, deshalb ist das Ergebnis FALSCH.

Die UND-Funktion als Argument

Mit der WENN-Funktion würdest Du die Formel so aufbauen:

=WENN(B42=1234;WENN(B43=255/10;WENN(B44=WAHR;WAHR;FALSCH)))

Ergebnis: WAHR

Verwende nun UND als Prüfargument:

=WENN(UND(B42=1234;B43=255/10;B44=WAHR);WAHR;FALSCH)

Ergebnis: WAHR

Was hast Du damit gespart? Die Formel ist nicht mehr geschachtelt. Alle Prüfbedingungen sind mit der UND-Funktion zusammengefasst.

Mit der Funktion WENNFEHLER lassen sich einzelne Zellinhalte auf Fehler prüfen.

Ein Beispiel:

In Zelle B76 steht die Zahl 2345, in B77 der Text „Wolke“. B76 soll durch B77 dividiert werden.

UND3

Schreibe in D76 diese Formel:

=WENNFEHLER(B76/B77;“Berechnung nicht möglich“)

Eine Zahl kann nicht durch einen Text dividiert werden, deshalb erhältst Du in D76 die Mitteilung „Berechnung nicht möglich“.

Ersetze den Wert in B77 durch eine Zahl. In D76 steht nun das Berechnungsergebnis.

Um die UND-Funktion auch hier zu nutzen, brauchst Du weitere Zellinhalte.

In B91 soll 27, in B92 die Zahl 15 stehen. Beide Werte willst Du multiplizieren.

UND4

Schreibe in D91 diese Formel:

=WENNFEHLER(UND(B76/B77;B91*B92);“Das geht so nicht!“)

Warum wird „Das geht so nicht!“ ausgegeben? Weil das erste Argument in UND, nämlich B76/B77 mit FALSCH bewertet wird. Insofern liegt ein Fehler vor.

Ersetzt Du nun den Wert in B77 wieder durch eine Zahl, wird in D91 ein WAHR ausgegeben, denn UND führt eine Wahrheitsprüfung durch.

Abschließend noch eine dritte Funktion, die NICHT-Funktion.

Diese Funktion prüft, ob ein Wert nicht mit einem bestimmten Wert übereinstimmt. Die Werte können numerisch, aber auch alphanumerisch oder Text sein.

UND5

Der Wert in B106, Wolke, ist WAHR, weil er nicht Wind ist usw.

Veränderst Du den Wert in B106 auf „Wind“, gibt die NICHT-Funktion in D106 FALSCH aus. Das wiederum ist richtig.

Setze nun die UND-Funktion als Argument in NICHT ein:

=NICHT(UND(B106=“Wind“;B107=5630;B108=“ZTE 88″))

Das Ergebnis ist WAHR, denn alle Bedingungen sind nicht wahr.

Veränderst Du einen Wert in B106:B108 so, dass darin der nicht gewollte Wert steht, z.B. B107 auf 5630, bleibt das Ergebnis WAHR, denn es sollen alle Werte zutreffen.

Veränderst Du alle Werte auf die nicht gewollten Inhalte, also B106 auf „Wind“, B107 auf 5630 und B108 auf ZTE 88, erhältst Du als Prüfergebnis FALSCH, denn alle Bedingungen zusammen treffen zu.
Für die Funktion NICHT ist das falsch.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s