Wie du Diagramme bedingt formatierst

Du arbeitest gern mit der bedingten Formatierung von Excel? Mit geht es genauso.

Du erstellst auch gern Diagramme in Excel, weil visuell viele Fakten noch schneller zu erfassen sind? Dann haben wir schon wieder etwas gemeinsam.

Und hast du auch schon einmal gedacht, wie praktisch es wäre, wenn du deine Diagramme bedingt formatieren könntest? Mir ist dieser Gedanke neulich gekommen.

Natürlich wissen wir beide, dass Diagramme nicht direkt bedingt formatiert werden können. Direkt nicht, aber indirekt schon, mit einem kleinen Trick.

Wie das geht, will ich dir hier zeigen.

Dir liegt eine kleine Wertetabelle vor, die die Basis für ein Diagramm sein soll. Die Tabelle formatierst du bedingt mit dieser Formel:

=B5>MITTELWERT($B$5:$B$13)

Die entsprechenden Zellen sollen rot ausgefüllt werden.

Diagrammbedingt1

Erstellst du aus dieser Wertetabelle nun ein Diagramm, sieht das zunächst so aus:

Diagrammbedingt2

Bedingt formatieren kannst du da nichts. Der Trick besteht nun darin, zunächst eine zweite Datenreihe zu erzeugen. Erweitere dazu deine Ausgangstabelle so:

Diagrammbedingt3

In die Zellen C5:C13 hast du die Formel

=WENN(B5>MITTELWERT($B$5:$B$13);B5;““)

geschrieben. Alle Werte, auf die diese Bedingung zutrifft, werden nun angezeigt. Kopiere sie und füge sie ins Diagramm ein.

Diagrammbedingt4

Nun hast du bei einigen der x-Werte 1-9 zwei Säulen. Das sind die x-Werte, bei denen in der obigen Tabelle die bedingte Formatierung gegriffen hat.

Eine Säule willst du jeweils aber nur haben. Klicke deshalb auf die Datenreihe in Ocker, rufe mit der rechten Taste „Datenreihen formatieren“ auf und stelle die Reihenachsenüberlappung auf 100% überlappend ein. Nach OK sieht dein Diagramm nun so aus:

Diagrammbedingt5

Die zweite Datenreihe hat sich über die erste Reihe geschoben. Dort wo die zweite Reihe keine Werte enthält, bleibt die erste Reihe sichtbar.

Ganz wichtig: Dein „formatiertes“ Diagramm reagiert natürlich dynamisch auf Veränderungen in der Wertetabelle.

Und neben der Mittelwertberechnung als Bedingung, kannst du jede denkbare andere Bedingung setzen, etwa das Maximum, das Minimum, den drittgrößten oder den viertkleinsten Wert der Tabelle.

Eine letzte Information noch. Das Verfahren funktioniert ganz sicher nicht bei allen Diagrammtypen. Ich habe oben es mit der einfachen Gruppierten 2D-Säule ausprobiert.

Und ich habe es mit den Gruppierten Balken ausprobiert, das geht auch.

Diagrammbedingt6

Wenn du es mit anderen Diagrammtypen ausprobieren solltest, mich würden deine Erfahrungen sehr interessieren.

Advertisements

Autor: Gerhard Pundt

Auf meiner Site https://clevercalcul.wordpress.com geht es um die Tabellenkalkulation mit Excel. Es wird über Funktionen, Diagramme, Basiswissen u.a.m. geschrieben.

3 Kommentare zu „Wie du Diagramme bedingt formatierst“

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s