Die Excel-Funktionen MITTELWERT und MITTELWERTA

Unter Mittelwert wird im allgemeinen Sprachgebrauch der Durchschnitt aus mindestens zwei Zahlen verstanden.

Die allgemeine Regel ist, die Zahlen einer Reihe zu addieren und die Summe durch die Anzahl der Zahlen zu dividieren.

In diesem Beitrag werden die Ergebnisse aus den Funktionen Mittelwert und MittelwertA gegenübergestellt und analysiert.

Welche Fallstricke können auftreten?

1. MITTELWERT

Die Funktion MITTELWERT, wie schon oben bemerkt, gibt das arithmetische Mittel einer Zahlenreihe zurück. Sie gehoert zur Kategorie der statistischen Funktionen.

Dazu wird eine Gruppe von Zahlen addiert und dann durch die Anzahl der Zahlen dividiert.

Die Syntax lautet:

=MITTELWERT(Zahl1;Zahl2;…)

Insgesamt können von 1 bis 255 Argumente in die Berechnung einbezogen werden. Die Zellen, in denen Argumente zu finden sind, müssen nicht zusammenhängend angeordnet sein. Sind sie verstreut, muss eben jede Zelle eingegeben werden.

Das gilt aber nur, wenn du die Zahlen einzeln in der Formeln auflisten willst.

Hast du einen Bereich von z.B. B1:B456 und schreibst du die Formel so:

=MITTELWERT(B1:B456)

dann wird die Funktion auch den Mittelwert errechnen, obwohle es mehr als 255 Argumente sind.

Enthalten die ausgewählten Zellen eine Null, erhöht dies zwar nicht die Summe, wird aber bei der Anzahl wohl berücksichtigt. Steht in einer ausgewählten Zelle nichts, geht dieses Argument weder in die Summe noch in die Anzahl ein.

Ein Beispiel:

mittelwert1

Die Summe der Zahlen beträgt:

=SUMME(B4:B9) =180

Als Anzahl berechnest du:

=ANZAHL(B4:B9) =6

Der Mittelwert lässt sich nun mit der Formel:

=SUMME(B4:B9)/ANZAHL(B4:B9)

errechnen, Ergebnis =30.

Einfacher geht es natürlich mit der Funktion:

=MITTELWERT(B4:B9) =30

Wie lautet nun das Ergebnis, wenn du mit der Funktion MITTELWERTA rechnest? Du weißt, dass diese Funktion nicht durch ANZAHL dividiert, sondern durch ANZAHL2, d.h., es werden auch Textwerte gezählt, die aber in der Summe keine Rolle spielen.

Du rechnest:

=MITTELWERTA(B4:B9)

Das Ergebnis ist auch jetzt =30. Was heißt das? Ganz einfach: die Datenreihe enthält keine Text-, sondern nur Zahlenwerte.

2. MITTELWERTA

Ein zweites Beispiel soll die Funktionsweise von MITTELWERTA deutlich machen. Das ist auch eine statistische Funktion.

Die Syntax lautet:

=MITTELWERTA(Zahl1;Zahl2;…)

mittelwert2

Mit der Formel

=MITTELWERT(B20:B28)

errechnest du =248,25 als Mittelwert.

Rechnest du mit

=MITTELWERTA(B20:B28)

erhälst du als Ergebnis =220,67 als Mittelwert.

Was ist nicht in Ordnung im Datenbereich, alle Werte sehen wie Zahlen aus?

Ein Wert ist schon mal im Bereich gekennzeichnet, der Wert in B25. Die Zelle ist als Text formatiert. Eine Zahl kann auch im Textformat geschrieben und rechts ausgerichtet werden. Das sieht aus wie eine Zahl, ist aber keine.

MITTELWERT rechnet daher nur mit den Werten in B20:B24 und B26:B28.

MITTELWERTA dagegen verwendet alle Werte von B20:B28, da ANZAHL2 auch Textwerte mitzählt. Das Ergebnis fällt hier deswegen geringer aus.

3. Fazit

Was kann nun mit der Funktion MITTELWERTA angefangen werden?

Du kannst sie nutzen, um festzustellen, ob Textwerte in einem Datenbereich vorhanden sind. Angenommen, du hast einen sehr umfangreichen Datenbereich, lässt sich das anders kaum prüfen.

Rechne also beides aus: MITTELWERT und MITTELWERTA.

Sind die Ergebnisse identisch, hat sich kein Textwert in den Datenbereich eingeschmuggelt.

Ist MITTELWERTA kleiner als MITTELWERT, sind ein oder mehr Textwerte vorhanden.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s