Summe über SVERWEIS auf mehreren Arbeitsblättern

Du arbeitest gerne mit der Excel-Funktion SVERWEIS?

Nun hast du eine Datei mit mehreren Arbeitsblättern, auf denen du jeweils eine Berechnung nach gleicher Art und Weise mit dem SVERWEIS vornimmst.

Die errechneten Werte je Arbeitsblatt möchtest du auf dem ersten Blatt summieren, und zwar mit einer 3D-Summe.

Soviel schon mal vorne weg: Das geht nicht!

Du musst daher nach einem Trick suchen, um das Ergebnis doch noch zu erhalten.

Mein Vorschlag: Ich arbeite mich Schritt für Schritt an das Problem heran und du schaust zu.

Mein Beispiel soll wieder im Obst- und Gemüsehandel spielen. In mehreren Orten wird eine Verkaufsliste (in kg) geführt. Je Ort wird die Liste in einem gesonderten Arbeitsblatt gespeichert. Für dieses Beispiel habe ich die Orte Ludwigslust (Tabelle2) und Eckernförde (Tabelle3) fiktiv ausgewählt.

susverweis1

susverweis2

Zuerst wende ich den SVERWEIS im Blatt2, also Ludwigslust, an und möchte die Gurkenmenge im Januar abfragen. Ich bestimme den Bereich A20:D24 als Argument Matrix, der Januar befindet sich in der Spalte 2 der Matrix.

Das Suchkriterium entnehme ich der Zelle B31. Per Datenüberprüfung habe ich für B31 die Liste Gemüse (A20:A24) zugelassen.

susverweis3

Der einfache SVERWEIS sieht so aus:

=SVERWEIS($B$31;A20:D24;2;FALSCH)  =87

Nun will ich die Summe der Werte Januar und Februar im Blatt Ludwigslust bilden.

=SUMME(SVERWEIS(B31;A20:D24;2;FALSCH);SVERWEIS(B31;A20:D24;3;FALSCH)) =172

Das geht nach mehreren Versuchen meiner Meinung nach nur so. Die Angabe der Spalten von … bis greift nicht.

Eine bessere Variante steht mir mit der Nutzung einer Matrixkonstante zur Verfügung. In meinem Artikel „So verwendest du Matrixkonstanten in Excel“ habe ich erläutert, wie das geht.

Ich setze hier also das Argument Spaltenindex als Matrixkonstante in die Formel ein.

{=SUMME(SVERWEIS(B31;A20:D24;{2;3};FALSCH))}  =172

Die Formel schließe ich als Matrixformel mit Strg + Shift + Enter ab.

Das Gleiche mache ich jetzt über zwei Arbeitsblätter.

{=SUMME(SVERWEIS(B31;Tabelle2!A20:D24;{2;3};FALSCH))+SUMME(SVERWEIS(B31;Tabelle3!D4:G8;{2;3};FALSCH))}  =397

oder

{=SUMME(SUMME(SVERWEIS(B31;A20:D24;{2;3};FALSCH));SUMME(SVERWEIS(B31;Tabelle3!D4:G8;{2;3};FALSCH)))}  =397

Die Lösungen sind durchaus brauchbar, Schwachpunkt ist jedoch die Matrixkonstante, die nicht dynamisch gestaltbar ist. Kommt der Monat März dazu, muss die Matrixkonstante auf {2;3;4} erweitert werden.

In meinem ober erwähnten Artikel habe ich eine Alternative aufgezeigt, die ich hier aber nicht darstelle.

Eine abschließende Idee wäre, die SVERWEIS-Formel in jedes Blatt, z.B. in M1 zu schreiben und dann die 3D-Summe zu berechnen.

Die Formel in M1 lautet:

{=SUMME(SVERWEIS(Tabelle1!B31;A20:D24;{2;3};FALSCH))}


Die 3D-Formel lautet:

=SUMME(Tabelle2:Tabelle3!M1)  =397

Advertisements

Autor: Gerhard Pundt

Auf meiner Site https://clevercalcul.wordpress.com geht es um die Tabellenkalkulation mit Excel. Es wird über Funktionen, Diagramme, Basiswissen u.a.m. geschrieben.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s