So verwendest Du die Excel-Funktion WIEDERHOLEN

WIEDERHOLEN ist eine Textfunktion von Excel.
Die Excel-Hilfe erläutert:

„Wiederholt einen Text so oft wie angegeben. Verwenden Sie WIEDERHOLEN, um eine Zeichenfolge (eine Basiszeichenfolge) in einer bestimmten Häufigkeit in eine Zelle einzugeben.“

Die Syntax schließlich lautet:
=WIEDERHOLEN(Text;Multiplikator)

Text ist die zu wiederholende Zeichenfolge. Multiplikator gibt an, wie oft die Zeichenfolge wiederholt werden soll.

Dazu zeige ich Dir ein paar Beispiele, die Du auf Deine Bedürfnisse anpassen kannst.

1. Zahlen wiederholen

Die Zahl 3 soll zehn mal und die Zahl 34 soll vier mal wiederholt werden.

Wiederholen1

Formeln:
G9 =WIEDERHOLEN(3;10)
G11 =WIEDERHOLEN(34;4)
Das Argument Text wird mit 3 bzw. mit 34 belegt.
Als Multiplikator setze ich 10 bzw. 4 ein.

2. Buchstaben wiederholen

Mit Buchstaben verhält es sich ganz genauso, nur ist zu beachten, dass das Argument Text bei Buchstaben in Anführungszeichen („) zu setzen ist.
Der Buchstabe X soll fünf mal und die Buchstaben ABC sollen drei mal wiederholt werden.

Wiederholen2

Formeln:
G16 =WIEDERHOLEN(„X“;5)
G18 =WIEDERHOLEN(„ABC“;3)

3. Sonderzeichen wiederholen

Mit Sonderzeichen verfahre ich wie mit Buchstaben. Auch hier ist das Text-Argument in „“ zu setzen.
Die Zeichen * und # sollen vier mal wiederholt werden.

Wiederholen3

Formel:
G23 =WIEDERHOLEN(„*#“;4)

4. Eine Zeichenfolge wiederholen

Die Zeichenfolge 64bN soll zwei mal wiederholt werden. Das Text-Argument muss ich auch hier wieder in „“ setzen.

Wiederholen4

Formel:
G28 =WIEDERHOLEN(„64bN“;2)

5. Zahlen multiplizieren, dann wiederholen

Diesmal will ich mit der Ergebnis aus WIEDERHOLEN noch rechnen. Es sollen die Zahlen 4 und 2 multipliziert und dann das Ergebnis drei mal wiederholt werden.

Wiederholen5

Formel:
G34 =WIEDERHOLEN(2*4;3)

Das Ergebnis aus WIEDERHOLEN ist keine Zahl, sondern ein Text. Zu erkennen ist das auch an der Ausrichtung des Ergebnisses in F34, linksbündig.
Allerdings ist das Produkt aus 2 und 4 eine Zahl, die dann, wie im Beispiel 1 durch die Funktion WIEDERHOLEN zum Text wird.

6. Mit Ergebnis rechnen

Nun will ich mit dem Ergebnis aus Beispiel 5 weiter rechnen. Ich wiederhole also diesen Schritt und multipliziere das Ganze dann mit der Zahl 5.

Wiederholen6

Formel:
G41 =WIEDERHOLEN(2*4;3)*5

Das Ergebnis wird nun durch die Multiplikation mit einer Zahl selbst zur Zahl.

7. Text aus Matrix entnehmen

Der zu wiederholende Text soll mit der INDEX-Funktion aus einer Matrix entnommen und fünf mal wiederholt werden.

Dies soll die Matrix sein:

Wiederholen7

Mittels der INDEX-Funktion hole ich aus der zweiten Zeile und der dritten Spalte den Wert 17 und verwende diesen als Text-Argument in der Funktion WIEDERHOLEN.

Wiederholen8

Formel:
G50 =WIEDERHOLEN(INDEX(B50:D52;2;3)&“ „;5)

8. Erzeugen von Grafikelementen

Für diese Beispiel verwende ich einen kleinen Plan-Ist-Vergleich.
Die Abweichungen in Spalte C will ich mit Hilfe der Funktion WIEDERHOLEN grafisch darstellen. Zwischen positiven und negativen Abweichungen muss ich dabei unterscheiden.

Als Wiederholungs-Text soll der Großbuchstabe „I“ genutzt werden. Es werden zwei Spalten (negativ bzw. postiv) benötigt.

Zusätzlich nutze ich eine WENN-Abfrage.

Wiederholen9

Als Formeln setze ich ein:
E65
=WENN(C67<0;WIEDERHOLEN(„I“;-C67);WENN(C65=0;““;““))
F65
=WENN(C65>0;WIEDERHOLEN(„I“;C65);WENN(C65=0;““;““))
Die Werte in Spalte E ordne ich rechts-, die in Spalte F linksbündig an.

9. Wenn die Grafikbalken zu lang werden

Es kann durchaus vorkommen, mit Sicherheit sogar, dass die Abweichungswerte größer ausfallen, als es die Grafik dann „vertragen“ kann.
Für diesen Fall empfehle ich Dir, die Abweichungswerte für die Grafik anzupassen. Das machst Du am besten, indem Du die Werte durch 10, 100 oder ggf. auch durch 1000 dividierst.

Wiederholen10

Als Formel in D82 habe ich in diesem Fall
=WIEDERHOLEN(„I“;B82/10)
verwendet und bis D89 herunter gezogen.

10. Balken in einer Zelle darstellen

Bisher habe ich in jeder Zelle einen Grafikbalken erzeugt. Nun besteht der Wunsch, z.B. drei Balken in einer Zelle unterzubringen.
Dazu verwende ich zusätzlich die Funktion ZEICHEN mit dem Argument 10. Damit wird ein Zeilenumbruch erzeugt.
Die ursprüngliche Grafik sieht etwa so aus:

Wiederholen11

Als Formel verwende ich
=WIEDERHOLEN(„g“;B101).
Die Schriftart ist Webdings.
Um Die Balken aus C101 bis C103 nun in einer Zelle unterzubringen, verwende ich diese Formel in C107:
=WIEDERHOLEN(„g“;B101)&ZEICHEN(10)&WIEDERHOLEN(„g“;B102)&ZEICHEN(10)&WIEDERHOLEN(„g“;B103)
Die Zellen C107:D107 formatiere ich so:
Ausrichtung: „Zeilenumbruch“ und „Zeilen verbinden“
Damit erhalte ich dieses Ergebnis:

Wiederholen12

Die Grafik befindet sich nun in einer Zelle.

Alle Beispiele findest Du auf der Beispieldatei, die Du Dir hier herunterladen kannst: WIEDERHOLEN

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s