Mit bedingter Formatierung Übereinstimmungen finden (eine Ergänzung)

In meinem Artikel am 07.08.2015 ging es darum, mindestens vier übereinstimmende Kriterien in Datensätzen in einem Auswertungsformular zu finden. Die Lösung ergab sich unter Verwendung der bedingten Formatierung. Allerdings mussten sich die Kriterien zusammenhängend im Datensatz befinden.

Die heutige Ergänzung zum Artikel zeigt eine Möglichkeit, Datensätze zu finden, auch wenn sich die Kriterien nicht zusammenhängend im Datensatz befinden.

Die Beispieltabelle sieht wieder ähnlich wie im ersten Artikel aus und enthält 28 Datensätze. Die Funktionalität ist natürlich auch bei 1000, 2000 oder mehr Datensätzen gegeben. Nur müssen die Formeln auf den jeweiligen Bereich abgeändert werden. Das aber dürfte für Dich nicht das Problem sein.

BedingtFormat1

Wenn jeweils mindestens 4 Kriterien übereinstimmen sollen, sind diese Konstellationen denkbar.

BedingtFormat3

Zeile 46 ist z.B. so zu lesen:

Die übereinstimmenden Kriterien befinden sich in der jeweiligen Zeile in den Spalten B, C, D und E.

Zeile 57 liest sich so:

Die übereinstimmenden Kriterien befinden sich in den Spalten C, D, E und G.

Mit UND-Formeln wird die Bedingung gesetzt. Die Formel für Zeile 57 lautet z.B.:

=UND($C7=$C$5;$D7=$D$5;$E7=$E$5;$G7=$G$5)

Die Formel für die bedingte Formatierung (auch wieder spaltenweise)  wird nun durch Verbindung aller für eine Spalte zutreffenden UND-Formel als ODER-Formel („Monster-Formel“) gebastelt. Jede UND-Formel, die die jeweilige Spalte beinhaltet, fließt ein. Dementsprechend enthält jede ODER-Formel exakt 10 UND-Formeln.
Dementsprechend enthält jede ODER-Formel exakt 10 UND-Formeln.

Im Bild oben sind die Fälle für Spalte B gelb unterlegt. Alle UND-Formeln aus Spalte F in der angehängten Datei gehören also zur ODER-Formel für die Spalte B.

Markiere zuerst den Bereich B7:B34, wähle im Menü Start die Bedingte Formatierung / Neue Regel und wähle „Formel der zur Ermittlung der zu formatierenden Zellen verwenden“.
Gebe dort folgende Formel ein bzw. kopiere sie hinein:

=ODER(UND($B7=$B$5;$C7=$C$5;$D7=$D$5;$E7=$E$5);UND($B7=$B$5;$C7=$C$5;$D7=$D$5;$F7=$F$5);
UND($B7=$B$5;$C7=$C$5;$D7=$D$5;$G7=$G$5);UND($B7=$B$5;$C7=$C$5;$E7=$E$5;$F7=$F$5);
UND($B7=$B$5;$C7=$C$5;$E7=$E$5;$G7=$G$5);UND($B7=$B$5;$C7=$C$5;$F7=$F$5;$G7=$G$5);
UND($B7=$B$5;$D7=$D$5;$E7=$E$5;$F7=$F$5);UND($B7=$B$5;$D7=$D$5;$E7=$E$5;$G7=$G$5);
UND($B7=$B$5;$D7=$D$5;$F7=$F$5;$G7=$G$5);UND($B7=$B$5;$E7=$E$5;$F7=$F$5;$G7=$G$5))

Suche Dir dann unzter Formatierung aus, ob Du die entsprechenden Zellen farbig ausfüllen oder die Schrift andersfarbig darstellen willst. Nach dem OK sind die entsprechenden Zellen hervorgehoben.

Verfahre mit den Spalten C bis G analog.

Abschließend willst Du wieder wissen, wie viele Datensätze es in Deiner Tabelle gibt, die in 4, 5 oder 6 Kriterien mit der Suchvorgabe übereinstimmen.

Dazu findest Du neben der Datentabelle eine kleine Tabelle, die diese Informationen gibt:

BedingtFormat2

Die darin enthaltenen Formeln sind diese:

J6    =ZÄHLENWENN(BD7:BD34;4)
K6    =ZÄHLENWENN(BD7:BD34;5)
L6    =ZÄHLENWENN(BD7:BD34;6)

Die Formeln greifen auf einen Hilfsbereich zu, den ich weiter rechts, im nicht sichtbaren Bereich des Arbeitsblattes deponiert habe, hier ein Ausschnitt:

BedingtFormat5

Darin enthaltene Formeln kannst Du der Datei entnehmen.

Die ganze Datei kannst Du Dir hier herunterladen:

BedingtÜbereinstimmungen

Advertisements

4 Kommentare zu „Mit bedingter Formatierung Übereinstimmungen finden (eine Ergänzung)“

  1. Noch eine Variante wäre (statt des Monsters): WAHR addieren. Hinter jedem WAHR steckt ja 1, und daher krieg ich die Information, ob von fünf Vergleichen vier oder mehr WAHR sind, auch so:
    =(($B7=$B$5)+($C7=$C$5)+($D7=$D$5)+($E7=$E$5)+($F7=$F$5))>=4

    lg
    Katharina

    Gefällt mir

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s