3 Anwendungen für das Steuerelement „Drehfeld“

Für den Excel-Nutzer ist es heute, da alles schnell und auf Knopfdruck erfolgen soll, unbedingt notwendig, einfach und komfortabel Exceldateien zu steuern. Dafür stellt Excel im Menü Entwicklertools die Steuerelemente-Toolbox zur Verfügung.

Mit Steuerelementen können verschiedene Planungsmappen, Monate, Filialen u.a. aufgerufen, aber auch Diagramme dynamisiert werden.

In diesem Beitrag will ich Dir drei Anwendungsmöglichkeiten des Steuerelements Drehfeld zeigen. Das Drehfeld sollte immer dann genutzt werden, wenn es um eine überschaubare Anzahl von Auswahlelementen (max. 20) geht. Bei größerer Anzahl wählst Du besser das Steuerelement Bildlaufleiste.

Auswahl aus einer Liste, Ausgabe Name und Alter

An einem Beispiel ist das besser zu sehen. Du siehst hier eine Liste mit Vornamen und rechts daneben das jeweilige Alter der Personen. Mittels einem Drehfeld willst Du z.B. den 6. Namen und das zugehörige Alter ausgeben lassen. Der Liste habe ich noch den Namen „Namen“ gegeben.

Drehfeld1

Gehe in das Menü Entwicklertool und wähle Einfügen, dann stehen Dir die Steuerelemente als Formularsteuerelemente oder als ActiveX-Steuerelemente zur Verfügung.

Drehfeld2

Bei den Formularsteuerelementen wählst Du in der ersten Reihe das vierte Element oder bei den ActiveX-Steuerelementen in der zweiten Reihe das erste Element aus. Über DSteuerelement formatieren kannst Du nun die Eigenschaften / Größe bzw. Steuerung einstellen. Die Einstellungen für dieses Beispiel siehst Du in der angehängten Datei.

Drehfeld3

Hier ist nun die „1“ ausgewählt. Mit der Formel =INDEX(Namen;D9;1) in E9 erhälst Du den gesuchten Namen, mit der Formel  =BEREICH.VERSCHIEBEN($A$6;D9;1) in F9 das zugehörige Alter.

Ein Diagramm beeinflussen

Die zweite Anwendung dient der dynamischen Beeinflussung eines Diagramms. Die y-Werte in einer Wertetabelle, die als Basis für ein Diagramm dient, werden nach folgender Formel berechnet:

Gleichung: y = … x + 4

Die drei Punkte vor dem x werden durch das Drehfeld bestimmt. Der Wert in B30 ist variabel. In C25 steht folgende Formel: =B30*C24+4

Drehfeld4

Markiere die y-Werte, gehe im Menü auf Einfügen und suche ein Liniendiagramm aus, dann erhälst Du dieses Diagramm.

Drehfeld5

Nun kannst Du durch Betätigung des Drehfeldes das Diagramm verändern. Sehen wirst Du das vor allem an der Veränderung der Beschriftung der y-Achse.

Eine Formel auswählen und rechnen

Du hast zwei Werte und möchtest sie abhängig addieren, multiplizieren oder dividieren. Im Bild siehst Du, dass die Werte in B48 und D48 multipliziert werden sollen.

Drehfeld6

Um zu zeigen, dass die Drehfeldauswahl 2 Multiplikation bedeutet, schreibst Du in E50 die Formel:

=WENN(D50=1;“Addition“;WENN(D50=2;“Multiplikation“;WENN(D50=3;“Division“)))

In der Beispieldatei zeige ich Dir zwei Möglichkeiten, die Rechenoperationen auszuführen.

In I56 steht die Formel:

=WAHL(D50;B48+D48;B48*D48;B48/D48)

In I58 schreibst Du:

=WENN($D$50=1;B48+D48;WENN($D$50=2;B48*D48;WENN($D$50=3;B48/D48)))

Anordnung des Drehfeldes

Zum Schluss steht noch die Frage, wie das Drehfeld gedreht werden kann. Gleich vorweg, das geht nur mit ActiveX-Elementen.

Drehfeld7

Veränder einfach in den Eigenschaften bei Größe die Höhen- und Breitenverhältnisse und das Drehfeld hat senkrechte oder waagerechte Pfeile.

Download Drehfeld

Advertisements

Autor: Gerhard Pundt

Auf meiner Site https://clevercalcul.wordpress.com geht es um die Tabellenkalkulation mit Excel. Es wird über Funktionen, Diagramme, Basiswissen u.a.m. geschrieben.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s