Zahlenformate in Excel umschalten

(Neubearbeitung 15.07.2021)

Angenommen, Du hast in einer Tabelle einen Bereich mit Zahlenwerten. Eingestellt ist ein Zahlenformat ohne Nachkommastellen. Beim Anklicken einzelner Zellen siehst Du aber schon, dass es Nachkommastellen gibt. Das Format der gegebenen Werte willst Du nicht verändern.

Für Deine planerischen Überlegungen willst Du aber die Werte bis zur 3. Nachkommastelle sehen. Damit ergeben sich mögliche vier Zahlenformate:

0 / 0,0 / 0,00 / 0,000

Zum Umschalten fügst Du über Entwicklertools / Einfügen / Formularsteuerelemente ein Drehfeld in Deine Datei „Zahlenformat.xlsx“ (Download am Beitragsende) ein und nimmst bei den Eigenschaften die Einstellungen wie auf dem Bild zu sehen vor (außer Aktueller Wert). Mit „OK“ schließt Du den Vorgang ab.

Zum Umschalten empfehle ich Dir zwei Möglichkeiten:

Dazu wählst Du einen parallelen Spaltenbereich aus und trägst in E7 bzw. F7 folgende Formeln ein:

E7 =TEXT(A7;WAHL($C$7;“0″;“0,0″;“0,00″;“0,000″))

F7 =WENN($C$7=1;TEXT(A7;“0″);WENN($C$7=2;TEXT(A7;“0,0″);WENN($C$7=3;TEXT(A7;“0,00″);WENN($C$7=4;TEXT(A7;“0,000″)))))

Jetzt kannst Du das Drehfeld bedienen und die möglichen vier Formate abrufen. Die Formate müssen allerdings in den Formeln definiert sein.

Willst Du weitere Formate auswählen können, z.B. „#.##0,00“, musst Du die Formeln entsprechend erweitern oder ändern.

Beispieldatei:

Ein Gedanke zu „Zahlenformate in Excel umschalten“

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s