short + flush 06/2015

Der Monat Juni ist fast schon wieder zuende, höchste Zeit also für die Kurzbeiträge. Short + flush 06/2015 enthält diesmal diese Themen:

  • So kannst Du Datumdifferenzen mit DATEDIF berechnen!
  • Wie Du eine Matrix definieren kannst!
  • Die Funktion KÜRZEN

So kannst Du Datumdifferenzen mit DATEDIF berechnen!

Die Tabellenfunktion DATEDIF ist eine undokumentierte Funktion, sie ist deshalb nicht unter Formeln Funktionsbibliothek zu finden. Auch die Excel-Hilfe bietet keine unterstützenden Informationen. Mit der Funktion kannst Du die Differenz zwischen einem Anfangs- und einem Enddatum ausrechnen.

Die Syntax für diese Funktion lautet:  =DATEDIF(Anfangsdatum; Enddatum;Zeiteinheit)

Als Zeiteinheiten kommen, bezogen auf die Differenz zwischen beiden Daten, in Frage:

„Y“ Anzahl vollständiger Jahre
„M“ Anzahl vollständiger Monate
„D“ Anzahl ganzer Tage
„MD“ Differenz zwischen den Tagen in Anfangs- und Enddatum, Monate und Jahre werden ignoriert
„YM“ Differenz zwischen den Monaten in Anfangs- und Enddatum, Tag und Jahre werden ignoriert
„YD“ Differenz zwischen den Tagen in Anfangs- und Enddatum, Jahre werden ignoriert

Ein paar Beispiele dazu:

DateDiff1

Willst Du nun wissen, wieviel vollständige Jahre + vollständige Monate + ganze Tage zwischen zwei Daten vergangen sind oder anders ausgedrückt: Seit dem Anfangsdatum sind … Jahre + … Monate + … Tage vergangen, solltest Du so vorgehen:

DateDiff2

Die jeweiligen Formeln kannst Du der Beispieldatei DATEDIF entnehmen.

Wie Du eine Matrix definieren kannst!

Matrizen werden in vielen Excel-Funktionen als Kriterium benötigt, z.B.

Funktion INDEX                        =INDEX(Matrix;Zeile;Spalte)
Funktion SUMMENPRODUKT   =SUMMENPRODUKT(Array1;Array2; …)
Funktion SUMMEWENN            =SUMMEWENN(Bereich;Suchkriterium;Summe Bereich)
Funktion MTRANS                    =MTRANS(Matrix)
Funktion VERGLEICH               =VERGLEICH(Suchkriterium;Suchmatrix;Vergleichstyp)
u.a.m.

Wie definiert sich eine Matrix nun?

Mit der INDEX-Formel zeige ich, wie die Matrix angewandt wird.

1. über die Werte eines Bereichs

Matrix1

=INDEX(D18:D22;2;1)

=38

2. über Werte in geschweiften Klammern

{25;38;;99;12;1245}

=INDEX({25;38;99;12;1245};2;1)

=38

3. über einen namentlich benannten Bereich

Matrix2

Name D32:D36: „Werte“

=INDEX(Werte;2;1)

=38

4. über eine Definition im Namensmanager

Matrix3

Name: „Matrix1“

bezieht sich auf: D40:D44

=INDEX(Matrix1;2;1)

=38

5. Erzeugung der Matrix durch Berechnung

Matrix4

Die Matrix entsteht aus der Multiplikation der Werte in Spalte C mit den Werten in Spalte D, z.B. 3 * 38 = 114.

=INDEX((C48:C52)*(D48:D52);2;1)

=114

Diese Form der Matrix ist im Tabellenblatt nicht zu sehen, wird aber durch die Multiplikation erzeugt.

Die Funktion KÜRZEN

Die Funktion KÜRZEN gehört in Excel zur Kategorie „Mathematik und Trigonometrie.

KÜRZEN, so sagt es die Excel-Hilfe, schneidet die Kommastellen einer Zahl ab und gibt als Ergebnis eine ganze Zahl zurück.

Die Syntax ist einfach.

=KÜRZEN(Zahl;Anzahl_Stellen)

Zahl ist die Zahl, deren Stellen Sie abschneiden möchten.
Anzahl_Stellen ist eine Zahl, die angibt, wie viele Nachkommastellen erhalten bleiben
sollen.

Die Erläuterung des Begriffs und die Ausführungen zu Anzahl_Stellen widersprechen sich, die Excel-Hilfe scheint hier fehlerhaft. Die Erläuterung gibt an, dass als Ergebnis eine ganze Zahl zurück gegeben wird. Anzahl_Stellen gibt aber an, wie viele Nachkommastellen erhalten bleiben sollen. Die Begriffserläuterung ist daher nur zutreffend, wenn Anzahl_Stellen = 0 ist.

Am Besten lässt sich die Wirkungsweise der Funktion an Beispielen erklären.

Kürzen1

Die Formel in D82 lautet z.B.: =KÜRZEN(B82;C82)

Du siehst, dass Du die Anzahl der Stellen, die erhalten bleiben sollen, auch negativ angeben kannst.

Wann verwendest Du die Funktion KÜRZEN? Lass es die Leser und mich wissen, schreib einen Kommentar.

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s