Wie Du in Excel Wörter und Zeichen zählen kannst!

Warum solltest Du Wörter und Zeichen in Excel zählen wollen?

Wenn Du selber Artikel schreibst oder Tantiemen von der VG Wort erhalten möchtest, macht es Sinn, Wörter und Zeichen zählen zu können.

In diesem Beitrag erhältst Du Hinweise, wie Du dabei in Excel vorgehen kannst.

Manchmal werden in Gastartikeln mindestens 600 Wörter gewünscht, Blogger zum Bloggen empfehlen zum Teil, Artikel mit mindestens 1000 Wörtern zu schreiben und die VG Wort verlangt, dass Deine Artikel mindestens 1800 Zeichen (inkl. Leerzeichen) haben.

Du denkst jetzt aber, dass Du gar nicht in Excel schreibst, sondern erst einmal in Word oder gleich in HTML. Das mag ja sein, aber Du könntest jetzt auch in Excel schreiben und zählen, wenn Du wolltest. Und das gibt Dir doch ein gutes Gefühl, oder?

In Word ist das Zählen ganz einfach: Menü Überprüfen und „Wörter zählen“ anklicken. Hier hast Du sofort alle Dich interessierenden Angaben.

In Excel musst Du dazu auf bewährte Formeln zurückgreifen.

Fall 1: Der Text steht in einer Zelle (A24)

Zählen1

Die Länge des Textes beträgt insgesamt:

=LÄNGE(A24) =25 Zeichen

Davon sind Leerzeichen:

=LÄNGE(A24)-LÄNGE(WECHSELN(A24;“ „;)) =3 Zeichen

Länge ohne Leerzeichen:

=LÄNGE(A24)-(LÄNGE(A24)-LÄNGE(WECHSELN(A24;“ „;))) =22 Zeichen

Schließlich willst Du die Anzahl der Wörter wissen:

=LÄNGE(A24)-LÄNGE(WECHSELN(A24;“ „;))+1 =4 Wörter

Fall 2: Der Text steht in mehreren Zellen (A45:F45)

Zählen2

Mit den einfachen Formeln aus Fall 1 kommst Du jetzt nicht mehr aus. Du greifst deshalb auf die Funktion SUMMENPRODUKT zurück.

Die Länge des Textes beträgt insgesamt:

=SUMMENPRODUKT(LÄNGE(A45:D45)) =22 Zeichen

Davon sind Leerzeichen:

=SUMMENPRODUKT(LÄNGE(A45:D45)-LÄNGE(WECHSELN(A45:D45;“ „;))) =0 Zeichen

Länge ohne Leerzeichen:

=SUMMENPRODUKT((LÄNGE(A45:D45)))-(LÄNGE(A45:D45)-LÄNGE(WECHSELN(A45:D45;“ „;))) =22 Zeichen

Und nun noch die Anzahl der Wörter:

=SUMMENPRODUKT((A45:D45<>““)*(LÄNGE(A45:D45)-LÄNGE(WECHSELN(A45:D45;“ „;))+1)) =4 Wörter

Damit kannst Du außer Text auch ausgefüllte Tabellen durchzählen, wozu auch immer diese Informationen gebraucht werden.

Advertisements

Autor: Gerhard Pundt

Auf meiner Site https://clevercalcul.wordpress.com geht es um die Tabellenkalkulation mit Excel. Es wird über Funktionen, Diagramme, Basiswissen u.a.m. geschrieben.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s